[Cialug] Rookie installer having trouble

murraymckee at wellsfargo.com murraymckee at wellsfargo.com
Mon Aug 18 17:12:54 CDT 2014

Humm.  I'll have to think about that.  I hadn't considered a compressed intermediate image.  I thought it had to be moved directly from the source to the target, which was what I thought I was doing.  I think I've found the -r option on Clonezilla that will resize the image to the partition size after the copy.  I'm going to try that.  

It took over 3 hours to download Clonezilla yesterday at church, so I didn't get a chance to try it out.  I tried to write it to a DVD, but I don't know if that worked or not.  When I ran TUXBOOT I could see the D: drive, my CD/DVD drive, but when I chose output media I only had the choice of Hard Drive or USB.  I noticed during the evening service that the download had completed, but by the time the service was over my laptop battery was expended.

I'll have to see if I can resize the partition on my desktop machine.  I didn't know that was possible.  I thought once a partition had data in it the size couldn't be adjusted.  Maybe I can try that tonight.

Thanks for the suggestions.

Murray R. McKee

Operating Systems Analyst
Mainframe/Midrange Services

Wells Fargo Compute Platform Services  |  800 Walnut Street  |  Des Moines, IA 50309-3605
MAC N0001-037
Tel 515-557-6127 |  Cell 515-343-6630 |  Fax 515-557-6046 | Text pager: 5153436630 at vtext.com 

MurrayMcKee at WellsFargo.com

TOG Recognition

-----Original Message-----
From: cialug-bounces at cialug.org [mailto:cialug-bounces at cialug.org] On Behalf Of Matt
Sent: Sunday, August 17, 2014 12:02 PM
To: Central Iowa Linux Users Group
Subject: Re: [Cialug] Rookie installer having trouble

That's a bit much to try to reply to in one email, but I'll touch on one point...

When you do a drive backup of a bootable partition, you tend to have to do a block-level copy of the storage.  That copy doesn't know anything about what portions of the partition are chunks of files or what parts are "empty space" that are chunks of "deleted" files.  It just knows that there is a little boot loader block and a beginning and end point to the partition.  That basically means that, regardless of the amount of empty space there is in your filesystem, the backup will be the same size as the partition.

If you are using a ghosting/cloning utility, then you will end up with a drive that looks to windows as if it is the same size as the original drive, regardless of the amount of space there is on the new drive.  Clonezilla has the ability to do a drive copy that will resize the partition and filesystem to the full extent of the new drive, but not all drive cloning utilities do.  You can boot to a Linux LiveCD or the gparted Live CD to resize the partitions and filesystems to you heart's content, though.

If I were to do a system backup, I would use Clonezilla to do a compressed backup of the disk (including MBR if the disk contains a bootable system) that is saved to a file on a USB drive with a filesystem on it... Not as a direct working copy of the partition (for extra credit, use dd to create a file on the drive that eats all the unused space with 0s, then delete it so that Clonezilla gets a huge compression ratio and saves you a bunch of space in the backup).  This keeps the backup small and also allows you to save as many partitions or drives to the USB drive as it has space for.  You could then restore those images to the target drive as needed.

If you restore a "drive" image (rather than a single partition), you will have to use gpated (or you choice of other partition managers) to resize or create new partitions for a dual-boot scenario.  The reason you 1TB drive appears to be only 200GB is that it only has that one 200GB partition on it.  You can either resize that partition to take the full size of the drive, or you can create a new ~800GB partition in the unused (free) space of the disk (which will appear to Windows as a separate drive).

Hope this helps.

-- Matt (N0BOX)

Sent from my iPod Touch 5G

> On Aug 16, 2014, at 3:00 PM, <murraymckee at wellsfargo.com> wrote:
> I had really hoped to get further before I had to ask for help, but I didn't get that far.
> Here's the situation.
> I have two Windows XP laptops that I'd like to set up to dual boot to Linux and XP.  My wife doesn't want to learn something other than Picasa right now.  Once I get my laptop converted I'll do my wife's laptop.  The plan is to use XP & Picasa when not connected to the internet and Linux, Firefox, Thunderbird when connecting to the internet.
> They have 40G hard drives.  Mine is nearly full, the other one has some space.  
> I bought a pair of 64G USB drives.  One to use as backup.  I copied the 17G of data from my computer to one of the USB drives.  I've also copied it to a USB external hard drive as well.  Two backups is better than one.
> I bought a pair of 256G Crucial MX100 SSD to replace the hard drives.  
> I bought a Sabrent USB3 to SATA/IDE connector.  (I think USB-DSC8 is 
> the model or part number)
> Here's what I did last Saturday afternoon at church where I can access WIFI.  Out in the country we have dialup for personal e-mail.  Well, I guess it was 2 Saturdays ago now.
> I downloaded TUXBOOT & ? to do the drive copy from the hard drive to the USB.  (I tried to use EZ GIG IV but it didn't support the Sabrent connector.)  I can't find the down load of the copy code on my laptop, so I must have downloaded it directly to the USB, and it's wiped out now.
> I rebooted to TUX and copied from the hard drive to the SSD, or so I thought.  It ran for 45 minutes and failed.  I deleted some stuff, ran defrag, and tried again.  It failed again.  After several hours of work, finding what to use instead of what I thought I was going to use, downloading and installing it, and finally running it and failing twice, I gave up and went home.  It was well past supper time already.
> So, this afternoon I set the laptop back up here at home.  I'm using my work laptop for this e-mail as it has a cell modem.  I connected the SSD through Sabrent connector and looked at my two USB drives.  One contained my backup data as expected and had a capacity of 61G, 17G used.  
> I looked at the other one, expecting to see the TUXBOOT & ?, but found a copy of my "C" drive, and no tuxboot to be seen.  What surprised me even more that the USB drive was formatted to 40G and completely full.  I now guess that the USB is allocated in 4K blocks and the hard drive is allocated in something smaller and that caused the backup error.  Although both are NTFS file systems.
> What concerns me is that I can NOT see the SSD, even though there are two lights on the block at the other end of the cable from the USB connector that plugs into the laptop.  One appears to be indicating that there is a USB connection, and the other is labeled SATA.  I'm assuming that means that the block is talking to the SATA SSD drive.
> Since Windows can't see the SSD drive I'm guessing that TUXBOOT & ? can't either and I inadvertently selected the USB when I started the copy.  I didn't connect the SSD drive to the laptop until after I'd shut it down in preparation to boot TUXBOOT from the USB drive.
> I really wanted to make two or maybe three partitions on the SSD, one for XP and one for Linux, and possibly one for common data where both could read and write, well, one at a time, whichever one was booted at the time.  But if I use the same thing I used last weekend I'll end up with the same problem again.  Even if I figure out how to see the SSD, I'll get it formatted down to 40G and lose the other 200G of space and have no room to install Linux.
> So, the two questions I have for the computer wizards out there are:
> 1. Has anybody used a Sabrent USB-DSC8 to connect to an external SSD, and how do I get the computer to recognize the SSD drive?
> 2. How do I copy Windows to the Curcial SSD without formatting it down to 40G so I have room for Linux and data expansion?  Or should I install Linux on the new SSD first and then copy the XP system in?
> Or am I going about this all wrong and I need to start over farther back.
> Years ago I had a 200G hard drive on my home desktop computer, when that was huge, and it became flaky.  I bought a 1T drive to replace it and copied the entire drive over using the software that came with the new drive.  Now I can only access 200G on my 1T drive.  At the time it didn't worry me as I was more concerned with the drive being flaky.  In the intervening years I've used up most of the 200G and I'd love to use more space on my desktop, but I can't get at it.  I don't want the same thing to happen to my SSD.  Losing 1/3 of my USB is a nuisance.  Losing 80% of my SSD is not acceptable, especially when I need more space now.
> The other thing that happened was while I was trying to download TUXBOOT & ? I seem to have gotten way more than I wanted and every time I connect to the internet I get a constant stream of popup windows with advertising that I have to keep closing and then they open a browser window even though I said close.  I tried to uninstall some of it, but it seems to have deleted something that is required to uninstall software and I can't uninstall anything now.  Bummer!
> I'm sorry about such a long rambling e-mail, but I thought with enough details there was a better chance of getting an answer than resolves the problem.
> TIA,
> Murray R. McKee
> Operating Systems Analyst
> Mainframe/Midrange Services
> Wells Fargo Compute Platform Services  |  800 Walnut Street  |  Des 
> Moines, IA 50309-3605 MAC N0001-037 Tel 515-557-6127 |  Cell 
> 515-343-6630 |  Fax 515-557-6046 | Text pager: 5153436630 at vtext.com
> MurrayMcKee at WellsFargo.com
> TOG Recognition
> _______________________________________________
> Cialug mailing list
> Cialug at cialug.org
> http://cialug.org/mailman/listinfo/cialug
Cialug mailing list
Cialug at cialug.org

More information about the Cialug mailing list